Looks like you're not a member? Here at BMWBOX, we ♥ BMWs.

We’re a family full of enthusiasts from car detailing bods, performance freaks, photography experts and mechanical maniacs.

Sign up to the club

My E46 323Ci AC Schnitzer

Veteran
Posts: 1090
Joined: Mon Jun 15, 2015 10:19 am
Location: Near Brighton
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby Andy » Tue Jan 31, 2017 1:48 pm

Well done for getting it all done mate, looks like it was quite a task.
Image

Topic author
Veteran
Posts: 225
Joined: Sun Nov 01, 2015 10:27 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby shabs » Tue Jan 31, 2017 4:04 pm

Well done for getting it all done mate, looks like it was quite a task.
Well I had two weeks of annual leave to work on it. And I would have liked to do some things differently if I had more time.


Sent from my iPhone using Tapatalk

Veteran
Posts: 1090
Joined: Mon Jun 15, 2015 10:19 am
Location: Near Brighton
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby Andy » Tue Jan 31, 2017 6:53 pm

Well its a good amount of work to get done in two weeks. Bet it feels way better to drive now.

Dyno torque had my old coupe for about a week when they did it and they've done loads.
Image

Topic author
Veteran
Posts: 225
Joined: Sun Nov 01, 2015 10:27 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby shabs » Sat Feb 04, 2017 12:05 pm

Looks like my e46 is coming back on road today. Gearbox went on my banger run around.


Sent from my iPhone using Tapatalk

Topic author
Veteran
Posts: 225
Joined: Sun Nov 01, 2015 10:27 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby shabs » Sun Feb 12, 2017 7:57 pm

Hi, not sure if the 323i had a dual pipe exhaust box. But I have a remus AC Schnitzer exhaust backbox for sale if you're interested.
Usshuss, i sent you some PM's for the backbox, but they keep going to my outbox rather than the sent section, not sure if that means your inbox is full??

Topic author
Veteran
Posts: 225
Joined: Sun Nov 01, 2015 10:27 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby shabs » Fri Mar 03, 2017 9:20 am

Some updates on the car. So ever since it's been back on the road. I've been having issues. At times on low revs or idle. It would miss fire, or get a rough idle. Loads of codes where stored, fuel trim both banks, multiple mis fire, mis fire codes for various cylinders, manufacturer control.

Had it cutting out several times once fuel hit 1/4 and got worse the lower the fuel got to a point it refused to start. (Still had fuel in there I'm not that stupid lol)

And fuel gauge giving wrong reading.

Found the fuel pump wasn't working right. So new one in. That solves the cutting out issues.

But the random rough running and miss fires continued.

Checked my intake pipes. And both upper and lower where split. New ones in. Thought this should resolve all the issues.

Took her for a drive, light was still on as didn't have my reader to reset it, and drove allot nicer and smoother.

Reset the light and after a while it returned. But wasn't rough or miss firing this time. Got codes for fuel trim both banks.

So did the fuel filter last night. Reset the lights. All was fine.

Light came back today morning. Fuel trim bank 2. Reset it and hasn't come up yet.

I think the saga continues tho.

Will try cleaning the maff next. If that doesn't work I think it'll be the lambda sensors.


Sent from my iPhone using Tapatalk

Veteran
Posts: 1090
Joined: Mon Jun 15, 2015 10:19 am
Location: Near Brighton
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby Andy » Thu Mar 09, 2017 4:57 pm

Have you checked the hose that's part of the CCV which runs along the top of the engine next to the fule rail under the smaller plastic engine cover? They deteriorate after a while and can cause problems like you have.

Does yours have the emnmissions pump? The vbac lines to/from these can fail too.
Image

Topic author
Veteran
Posts: 225
Joined: Sun Nov 01, 2015 10:27 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby shabs » Thu Mar 09, 2017 9:20 pm

Have you checked the hose that's part of the CCV which runs along the top of the engine next to the fule rail under the smaller plastic engine cover? They deteriorate after a while and can cause problems like you have.

Does yours have the emnmissions pump? The vbac lines to/from these can fail too.
I checked some hoses, but dont think i had a look at that one. I have a secondary air up for cold starts if thats what you mean, those hoses seem fine.

I been messing around with that torque app and doi ng some research online. Not entirely sure what im looking at on it, but it seems like my bank 2 pre cat lamba sensor has gone as it doesnt seem to fluctuate on the entire range.

Topic author
Veteran
Posts: 225
Joined: Sun Nov 01, 2015 10:27 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: My E46 323Ci AC Schnitzer

Postby shabs » Wed Mar 29, 2017 8:05 pm

Just realised I didnt say what my issues where, got better at understanding the diagnostics on torque app. My precat bank 2 lambda was gone, So got a good deal on 2 new Bosch sensors at so bought both, initially just replaced the bank 2 sensor, and she was running allot better, but idle and cold start low revs where rough. with my short term fuel trims being high on both banks (as you can see allot of learning has happened aha)

Checked everything again, ccv all good, but found that my DISA is the culprit, it was fine when i checked it before but when you close the flap and block the hole on the vacuum pot thing, it slowly opens completely. Wont close on idle either, if I make it close while on idle, it will happily idle with no issues, and all the fuel trim values will be perfect.

After i found that out, the other lambda sensor died, so replaced that aswell. Since replacing that, shes been almost perfect, just cold mornings for a very short while she will be rough on low revs when driving, and occasionally the light will came back for fuel trim bank 1 and 2. So im assuming this must be down to the DISA?

Instead of replacing just the DISA I think im going to do a M54 inlet swap

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “Car Chit Chat”

Who is online

Users browsing this forum: No registered users and 2 guests